editors/libreoffice:internal build errors: ERROR: error 65280 occurred while making /usr/ports/editors/libreoffice/work/libreoffice-core-

Jens Jahnke jan0sch at gmx.net
Thu May 31 17:35:50 UTC 2012


On Fri, 04 May 2012 14:12:17 +0200
"Hartmann, O." <ohartman at zedat.fu-berlin.de> wrote:

HO> I found myself incapable of rebuilding/updating editors/libreoffice
HO> on ALL FreeBSD 9-STABLE and FreeBSD 10-CURRENT (amd64) platforms
HO> with the very same error message as shown below.

I ran into the same issue on my 9-STABLE box at home today.
If I follow the steps provides in the error message it compiles a bit
further and gives the exact same error message some modules later.
Anyhow I stepped through them and finally got another error message:

[ build CUT ] lotuswordpro_test_lotuswordpro
R=/usr/ports/editors/libreoffice/work && S=$R/libreoffice-core-
&& O=$S/solver/unxfbsd.pro && W=$S/workdir/unxfbsd.pro &&  mkdir -p
$W/CppunitTest/ && (LD_LIBRARY_PATH="$O/lib":$O/lib/sqlite
--headless --protector unoexceptionprotector.so unoexceptionprotector
"-env:UNO_TYPES= file://$O/bin/udkapi.rdb  file://$O/bin/types.rdb"
file://$O/xml/configmgr.component  file://$O/xml/ucb1.component
-env:URE_INTERNAL_LIB_DIR=file://$O/lib  -env:LO_LIB_DIR=file://$O/lib
> $W/CppunitTest/lotuswordpro_test_lotuswordpro.test.log 2>&1 || 
(cat $W/CppunitTest/lotuswordpro_test_lotuswordpro.test.log && echo;
echo "Error: a unit test failed, please do one of:"; echo; echo "export
DEBUGCPPUNIT=TRUE            # for exception catching"; echo "export
GDBCPPUNITTRACE=\"gdb --args\" # for interactive debugging"; echo
"export VALGRIND=memcheck            # for memory checking" ; echo "and
retry." && false))

Abort trap (core dumped) File tested,Test
Result,Execution Time (ms)
11 during cups initialization called, ignoring cups

Error: a unit test failed, please do one of:

export DEBUGCPPUNIT=TRUE            # for exception catching
export GDBCPPUNITTRACE="gdb --args" # for interactive debugging
export VALGRIND=memcheck            # for memory checking
and retry.
gmake: ***
Error 1

The mysterious thing is that I have a nearly identical box at the office
running 9-STABLE and there libreoffice compiles fine.
It only differs in two hardware components:
CPU is core2 at home and core5i at the office.
RAM is 4gb at home and 8gb at the office.

System on both is clean installed and updated 9-STABLE.

So maybe this is a memory/cpu issue?



31. Wonnemond 2012, 19:29
Homepage : http://www.jan0sch.de

I can resist anything but temptation.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 704 bytes
Desc: not available
Url : http://lists.freebsd.org/pipermail/freebsd-questions/attachments/20120531/b14ba45c/attachment.pgp

More information about the freebsd-questions mailing list