Can't get irc/inspircd to build, any clues?

Polytropon freebsd at
Mon May 28 08:46:06 UTC 2012

On Mon, 28 May 2012 04:30:14 -0400, Howard Leadmon wrote:
>  Does anyone know if the irc/inspircd port for FreeBSD works?    I have
> tried it on an FBSD 9 server, as well as an older version of the FreeBSD
> with the same results.
>  If I try and run make the build the port, I get the following error:
> # make
> ===>  Building for inspircd-2.0.5
> make: cannot open BSDmakefile.
> *** Error code 1
> Stop in /usr/ports/irc/inspircd.
> *** Error code 1
> Stop in /usr/ports/irc/inspircd.
> #

> I figure maybe someone has gotten this to build, so figured I would toss it
> out here as using my googlefu I found years ago someone posting the same
> problem, but never found any resolution.   

Just tried "very carefully", all steps seem to work fine
(OS 8.2-STABLE/x86 of August 2011 here, ports tree not
fully up to date, so port version is just 2.0.2):

	# make config
	# make fetch
	# make extract
	# make

I interrupted the "make" stage as everything seemed to
compile normally. As I said, the installation here is
already a bit old, but I hesitate to update anything
because, you know, never touch a running system. :-)

Make sure your ports tree is okay. The file mentioned
in the error message should be extracted intowork/:

Do a "make clean" before you try again.

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list