portsnap update won't update original /usr/ports

Thomas Mueller mueller23 at insightbb.com
Wed May 23 01:30:52 UTC 2012

----- Original Message -----
From: Gary Aitken <freebsd at dreamchaser.org>
To: freebsd-questions at freebsd.org
Sent: Tue, 22 May 2012 19:02:30 -0400 (EDT)
Subject: portsnap update won't update original /usr/ports

According to the handbook, one can do
   portsnap fetch
   portsnap update
and the update will work with a previously created ports tree;
I presume this includes one created during system install.

However, when I attempted this, portsnap complained:
   /usr/ports was not created by portsnap.
   You must run 'portsnap extract' before running 'portsnap update'.

Is there a way to use portsnap against this tree, or must I delete the 
existing /usr/ports and do an extract first?



---- My response: ----

I screwed up this way too, when I downloaded the USB memstick image for FreeBSD 9.0_BETA1 and later, BETA2, I installed the ports from that, which worked to my disadvantage when I later ran "portsnap fetch update".

I wound up deleting /usr/ports/* and starting fresh, may not necessarily have had to delete the ports tree.  But now it works.

Now I wonder if it's feasible to switch between "portsnap fetch update" and csup <ports-supfile>, or if it's strictly one or the other.

I am at webmail interface, which strongly favors top-posting over bottom-posting; feel more comfortable with vi editor.

More information about the freebsd-questions mailing list