FreeBSD: SOLVED: FreeBSD9 - I can't get my mouse to work (was : FreeBSD9 - I can't get my mouse to work)

Walter Hurry walterhurry at
Fri Jun 8 15:51:38 UTC 2012

On Fri, 08 Jun 2012 15:39:22 +0000, Walter Hurry wrote:

> On Thu, 07 Jun 2012 14:59:01 -0400, Jerry wrote:
>> Ubuntu,
>> Debian, and Fedora, and projects such as KDE, GNOME and are in
>> the process of deprecating HAL as it has "become a large monolithic
>> unmaintainable mess".
> Well, I finally got it working. I'm far from an expert in this area, but
> what I think was happening was that the touchpad was grabbing /dev/psm0,
> and then tried to allocate the same port for the USB mouse, which
> of course failed (even though I had specified a Device of /dev/ums0, and
> set AutoAddDevices to Off so as to take hald out of the picture).
> The solution for me was to run moused *on port /dev/ums0* and then
> specify the device as /dev/sysmouse in xorg.conf.
> However, that leads me to another question: my amateurish way to get
> moused to run on /dev/ums0 was to hack /etc/rc.d/moused and hard code
> it.
> I don't think that's very good, and I suspect that the "right" way to do
> it was to set some variable in /etc/rc.conf.
> Can anyone guide me on how that should be done, or point me to a fine
> manual?
> Thamks to all for the responses.
Never mind: Stupid moi. The answer was staring me in the face in man 
rc.conf. moused_port.

More information about the freebsd-questions mailing list