umount device busy

Gary Aitken freebsd at
Mon Jun 4 19:52:32 UTC 2012

On 06/04/12 02:28, Lars Eighner wrote:

>>> This almost always means someone (i.e. you) is sitting in the directory.
>>> If you tried this while su'ed and the un-su'ed you were still in the
>>> directory /mnt/goflex, you'd get this message. This may also happen if
>>> someone (i.e. you) is in the directory on another vtty. Naturally it can
>>> also mean some operation is in progress, but generally you would have
>>> recognized and avoided that.
>> That's what I kept thinking. Backed out of all su ops, checked all
>> xterms; nada. no other vtys opened. In any case, the mount was done
>> after X was started, and switching vtys crashes X so I don't do that.
> This needs fixing.

no kidding.
at the moment, other stuff has priority...

>>>> 3. I tried lsof but I don't get any output from it:
>>>> lsof +d /mnt/goflex -x -- /mnt/goflex
>>>> Where does it go if not to stdout?
>>> You've got me! But why is there anything after -x? I don't quite
>>> understand.
>> Otherwise -x thinks the /mnt/goflex belongs to it.
> But what if you leave out ALL the stuff after -x. Isn't it redundant with
> the +d switch? (That's not a Socratic question: I don't know.)

That's what you get when you build a command line while reading the man page :-)
At least in this instance, you get the same result.

> Anyway, I found the lsof FAQ by make extract in the port. I quess I am not
> too good at reading Makefiles because I don't see why it isn't copied to
> /usr/local/share/lsof with the README and whatnot.

Thanks, got it.


More information about the freebsd-questions mailing list