umount device busy

Lars Eighner portsuser at
Mon Jun 4 08:30:23 UTC 2012

On Sun, 3 Jun 2012, Gary Aitken wrote:

>> This almost always means someone (i.e. you) is sitting in the directory.
>> If you tried this while su'ed and the un-su'ed you were still in the
>> directory /mnt/goflex, you'd get this message. This may also happen if
>> someone (i.e. you) is in the directory on another vtty. Naturally it can
>> also mean some operation is in progress, but generally you would have
>> recognized and avoided that.
> That's what I kept thinking.  Backed out of all su ops, checked all
> xterms; nada.  no other vtys opened.  In any case, the mount was done
> after X was started, and switching vtys crashes X so I don't do that.

This needs fixing.

> I thought maybe so, but didn't know for sure.  Thanks.
> But Lars' "mount -p" is more assuring.

I like it because if you happen to have a configuration you would
like to use again, you can capture the output and make it your
fstab, + or - automount adjustments.

>>> 3.  I tried lsof but I don't get any output from it:
>>>        lsof +d /mnt/goflex -x -- /mnt/goflex
>>>        Where does it go if not to stdout?

>> You've got me! But why is there anything after -x? I don't quite
>> understand.
> Otherwise -x thinks the /mnt/goflex belongs to it.

But what if you leave out ALL the stuff after -x.  Isn't it redundant with
the +d switch?  (That's not a Socratic question: I don't know.)

Anyway, I found the lsof FAQ by make extract in the port.  I quess I am not
too good at reading Makefiles because I don't see why it isn't copied to
/usr/local/share/lsof with the README and whatnot.

>> man -t lsof | sp2ascii > savefile.txt
> Where'd you get/find sp2ascii?  I don't see one anywhere, not even on google.
> (Except this thread...)  Secret weapon?

That's a good question.  Turns out all kinds of ps converters are installed
by ghostscript.

Lars Eighner
8800 N IH35 APT 1191 AUSTIN TX 78753-5266

More information about the freebsd-questions mailing list