Strange case of vanishing disk

Graeme Dargie arab at
Mon Jun 4 17:02:24 UTC 2012

-----Original Message-----
From: owner-freebsd-questions at [mailto:owner-freebsd-questions at] On Behalf Of Kaya Saman
Sent: 04 June 2012 02:07
To: freebsd-questions at
Subject: Strange case of vanishing disk


this is a very strange issue but I guess will either be related to 2 things, PSU not being powerful enough or disk controller simply being crap.

Here's what's going on. I have a little Chenbro 4 disk mini-ITX NAS 
server with 2x 2TB disks and 2x4TB disks as storage - all spread out 
over 2 ZFS storage pools. Additionally I am running the root file system 
on a 40GB SSD.

The strange thing with this is that I recently installed the 4TB disks 
and they're brand new.

One disk connected to the system board works fine and shows up as online 
and on one of the channels using atacontrol list.

The other disk is connected to a Jmicron based 2x SATA RAID 
controller card.

The disk connected to the controller card is having issues. At first the 
drive wouldn't be seen by the system then after a while all of a sudden 
it was there. No reboots, no io scans nothing it just appeared.

After blasting it with IO for a few days the disk has now vanished 

I had this error in dmesg for a while:

ad4: TIMEOUT - READ_DMA retrying (1 retry left) LBA=113337535

I have tried to use pciconf -lbvv to show the connected interfaces and 
the JMICRON comes up fine:

atapci0 at pci0:2:0:0:    class=0x010400 card=0x2366197b chip=0x2366197b 
rev=0x02 hdr=0x00
     vendor     = 'JMicron Technology Corp.'
     device     = 'JMicron JMB366 AHCI/IDE Controller (JMB36X)'
     class      = mass storage
     subclass   = RAID
     bar   [10] = type I/O Port, range 32, base 0xd040, size  8, enabled
     bar   [14] = type I/O Port, range 32, base 0xd030, size  4, enabled
     bar   [18] = type I/O Port, range 32, base 0xd020, size  8, enabled
     bar   [1c] = type I/O Port, range 32, base 0xd010, size  4, enabled
     bar   [20] = type I/O Port, range 32, base 0xd000, size 16, enabled
     bar   [24] = type Memory, range 32, base 0xd0510000, size 8192, enabled

So why isn't the disk?

I reckon as stated at the beginning that either the 180Watt PSU inside 
the system isn't enough or the controller is just really poor??

Could anyone suggest anything to look into, I'm sure I've covered all 
the bases but just incase there is something else I can do with this one??


freebsd-questions at mailing list
To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

I have had a similar issue on a 3 machines before and in each case the cause was slightly different, on one updating the motherboard BIOS updated the AHCI microcode and the problem went away, another it was the power supply that was a little under powered and in the third which was much more odd was a faulty ram socket on the motherboard, in that case I had initially thought it was the on board sata controller that was the issue so I tried a new 6 port sata controller but the behaviour was the same, so I know it sounds strange but run memtest and see if throws up an errors.



More information about the freebsd-questions mailing list