umount device busy

Gary Aitken freebsd at
Sun Jun 3 14:59:12 UTC 2012

Something I'm overlooking here and a lot of questions I can't seem to find the answers to...

I mounted a usb drive
  mount -t ntfs /dev/da0s1 /mnt/goflex 

Then, as nearly as I can remember...
  I then poked around a bit using the xfce4 browser.
  I tried to mkdir from the mount point as a normal user:
    cd /mnt/goflex
    %mkdir breakaway
    mkdir: .: No such file or directory
  After checking write premissions, which I didn't have,
  I did an su -l and tried again, with the same results.

I then tried to unmount the drive, believing it was mounted read-only:
    #umount /mnt/goflex
    umount: unmount of /mnt/goflex failed: Device busy

As nearly as I can tell, I don't have anything pointing at that drive.


1.  What does the "No such file or directory" mean from mkdir?
    It's a relative dir name, and I'm sitting at a valid dir.

2.  How do I find out how the file-system was mounted?
    mount (noargs) does not show read/write status

3.  I tried lsof but I don't get any output from it:
      lsof +d /mnt/goflex -x -- /mnt/goflex
    Where does it go if not to stdout?

4.  lsof has a *long* man page, so I'd like to save it temporarily so I can search it in an editor.  If I do man lsof >temp.tmp the output contains backspace sequences which screw up searching.  How do I get man to produce plain text without the control sequences?

5.  The lsof man page references a faq which is supposed to be part of the distribution.
    find . -ls | grep lsof doesn't show any faq.

6.  And finally, any idea why umount says the device is busy?

Seems like I should have been able to find the answer to at least one of those but I'm coming up short.

Thanks for relevant pointers,


More information about the freebsd-questions mailing list