Apache segmentation fault

Waitman Gobble gobble.wa at gmail.com
Wed Jan 11 21:39:37 UTC 2012

On Jan 11, 2012 12:54 PM, "Waitman Gobble" <gobble.wa at gmail.com> wrote:
> On Jan 11, 2012 12:39 PM, "Robert Fitzpatrick" <robert at webtent.org> wrote:
> >
> > Upgraded php52 to php53 by pkg_delete of php5 and porinstall php52. Then
> > I had to manually resort back to php52 by pkg_delete and then
> > portinstall and now getting a seg fault when restarting apache22 on this
> > FreeBSD 8.1 server. I narrowed it down to not the php module, but the
> > two ldap modules I have in apache...
> >
> > mail# cat httpd.conf|grep ldap
> > #LoadModule authnz_ldap_module libexec/apache22/mod_authnz_ldap.so
> > #LoadModule ldap_module libexec/apache22/mod_ldap.so
> >
> > With these two lines commented out, apache restarts without the seg
> > fault. Tried to force pkg_delete on apache and then portinstall to
> > rebuild these modules, but same issue afterward. The php module loads
> > without error, but getting download prompts when trying to access php
> > pages. Not getting any help from messages or httpd-error logs and all
> > was working before I messed it up.
> >
> > My question is what I should try next to try and fix this issue. Should
> > I force pkg_delete and rebuild all php packages or ldap packages? Or
> > some other approach?
> >
> > Thanks for any help, Robert
> >
> > --
> > Robert <robert at webtent.org>
> > _______________________________________________
> > freebsd-questions at freebsd.org mailing list
> > http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> > To unsubscribe, send any mail to "
freebsd-questions-unsubscribe at freebsd.org"
> hi, you probably need to replace php.ini ... 5.3 barfs with a 5.2  config
file... not sure if the pkg thingy would wipe your config.
> waitman

sorry, somehow i missed that paragraph about commenting out the other
modules... hope i didn't send you on a wild goose chase for nothing. but
the behavior you describe sounds like what happens running with a
mismatched php.ini... i once tried to narrow down but decided it more
productive to start with a fresh ini file. i believe the problem has to do
with the session config lines. that and the way it handles cgi variables
(see the EPGS section) are the two biggest changes i noticed.   anyway you
might check if thats the issue easily by renaming php.ini.. it should run
without it. (at least 5.2 would havent tried 5.3)
if it runs without php.ini then that  could be the problem.
by the way you are restarting apache after the changes right? also verify
that the modules listed in httpd.conf exist in the paths specified...

hope that helps!


More information about the freebsd-questions mailing list