9.0-RELEASE amd64 Bricked My Hard Drive

Devin Teske devin.teske at fisglobal.com
Fri Jan 6 03:56:41 UTC 2012

On Jan 5, 2012, at 7:16 PM, Bill Tillman wrote:

> Today I encountered a problem which has me stumped. I downloaded and
> burned the ISO image for 9.0-RELEASE for amd64. I  installed an older
> IDE hard drive to test the new OS with and did the install. I was very
> surprised at the (1) the dvd is actually a live CD if you wanted it to be
> and (2) the installers screens have all been revamped. I can't say for sure
> if the partitioning part was where it went south on me because I was
> attempting to setup some additional partitions but the input screens had
> me confused and I pressed Auto so it took off and made the default
> paritions. I thought cool, I'll let the install finish and check things out then
> reinstall later with the partition setup I wanted. Well the install finished and
> then I attempted to reboot the system but nothing happened. And by that I
> mean the computer's flash screen would come up and give me the choice
> to enter the Bios Setup or Boot Menu and that's all. I could not enter the
> bios setup or the Boot menu. The keyboard was still responding as I
> could press the CapLock key and toggle the light on and off, but outside
> of that the computer would not boot. On the advice of some of the techs
> in #FreeBSD channel I moved the drive over to another computer which
> was working fine, and the same thing happened. The computer would
> start up, show me the flash screen to do the Bios setup and then nothing.
> I put the other drive back in and it worked fine. I tried another computer
> and the results were the same. Now it gets really wierd. I thought that I
> could just make this IDE drive a slave and boot with another drive and
> cleanup the mess. But no matter which computer I chose, and no matter
> how I setup the Slave/Master drive, as long as this drive which I had
> installed FreeBSD-9.0-amd64 was in the loop, the computer would
> lockup at the bios screen. I could not get anything to boot if this drive
> was in the loop. If I removed it everything was fine. So basically,
> FreeBSD-9.0-RELEASE bricked an otherwise good 80GB hard drive
> and I can't seem to recover it.
> Any suggestions would be appreciated.   

Can you get into the BIOS of the original machine *while the bad drive is disconnected* ?

If so, I'd try changing the boot options in the BIOS to boot from something like external USB but not from IDE.

You'll want to find settings that are geared towards totally eliminating the possibility that the BIOS will scan the drive as a boot device.

Depending on your BIOS settings, this may involve changing the "Boot Order" to not include IDE (or ATA), or if you find it as a numbered boot device, disabling that numbered device (e.g. you see "Boot Device 2" and it says "IDE", see if it offers "Disabled" as an option).

If you can successfully change your boot options in the BIOS to not scan the IDE channels, ... remember, the drive is still not connected at this point ... then you should be able to connect the drive and get the same result -- the BIOS will tell you there's no bootable devices attached (as you've, hopefully, been able to disable that source of devices from the list of those probed/scanned).

At this point, you now need to find something other than IDE to boot from (as you've now disabled that type of device -- including CD/ROM).

Hopefully your system is new enough to boot from USB media.

Grab DruidBSD Tools disk on another (working) machine ...


Descriptions here:

Get yourself a USB thumb drive.

NOTE: Say goodbye to what's currently on your thumb drive -- make backups to another machine before you do this.

1. Execute before you attach your thumb drive: sysctl kern.disks
2. Insert thumb drive
3. Execute after you've attached the thumb drive: sysctl kern.disks
4. Identify the newly-available "da#" device
5. Execute (replacing "da#" with the appropriate device name) as root (or sudo(8)):

	dd if=Druid-0.0.iso of=/dev/da# bs=512k conv=sync

HINT: You can press Ctrl-T while it's writing the ISO file to the thumb drive to get a (somewhat) helpful progress indication.

When finished, you can use your USB thumb drive to do all sorts of rescue-work, including wiping the bad drive with Darik's Boot and Nuke (lol) -- used for secure government wipes -- or Active (R) Kill Disk Free Edition, both on the disk linked-to above. There's also Seagate Disk Utilities, which some of our field engineers found useful (I think it-too has a disk-wiper).

The information contained in this message is proprietary and/or confidential. If you are not the intended recipient, please: (i) delete the message and all copies; (ii) do not disclose, distribute or use the message in any manner; and (iii) notify the sender immediately. In addition, please be aware that any message addressed to our domain is subject to archiving and review by persons other than the intended recipient. Thank you.

More information about the freebsd-questions mailing list