Cant boot 9-RELEASE on Intel L440GX+ based system

jb jb.1234abcd at
Fri Aug 3 01:14:44 UTC 2012

Sergey Listopad <psychosensor <at>> writes:

> Hi.
> I try to boot topic on retro dual PIII Intel L440GX+ based system. It
> is onboard AIC-7896 SCSI controller with 1 COMPAQ HDD. CDROM is IDE.
> When I try boot from installation CD, boot stuck on
> CD Loader 1.2
> ...
> BTX loader 1.00 BTX version is 1.02
> Consoles: internal video/keyboard
> BIOS CD is cd0
> BIOS drive A: is disk0
> If I remove HDD, system (/boot/loader) boot from CD just fine. Then I
> insert HDD (hotswap) and able to install on it. But after reboot (with
> installation CD disk removed from drive) system unable to boot. And
> stuck on the same place, after
> ...
> BIOS drive A: is disk0
> Maybe anybody can help me to resolve this issue. I can post any
> additional information which may be helpful.
> Thanx.

This has been reported for FreeBSD and PC-BSD for quite some time.

The booting sequence always looks like this:
BIOS drive A: is disk0   <-------------------- last message seen
BIOS drive B: is disk1   <-------------------- or this

Based on Google search results:
- solved by disabling SATA in BIOS
- combination of IDE (ATA) and SATA disks caused a problem, disconnecting 
  either one solved it; it could also mean a problem with hd device driver
- old/buggy firmware; BIOS update solved the problem
- disable ACPI, or Firewire, or USB emulation, or ... in BIOS :-)
- "A wild guess could be that there's something on the RAID volume that's
  keeping the boot loader from working. Maybe the partition table is wrong
  in a subtle way? If you can get the RAID array to work *after* you boot
  from a FreeBSD installation CD (i.e. boot the machine without the
  drives, add drives later), try clearing the first megabyte of the array
  (dd if=/dev/zero of=/dev/yourdrive bs=1m count=1)."
- "With my rocketraid somethingsomething PCI-SATA2 card with disks
  connected crashes the BTX loader. Connecting the disks to the internal
  via epia motherboard solved the problem ...
  I have a feeling that it might be some combinations of BTX, BIOS and
  RAID firmware that causes these crashes."
- CC'ing John Baldwin on this, as he has knowledge of BTX's internals.

For those of you who are adventurous:


More information about the freebsd-questions mailing list