Samba question

Polytropon freebsd at
Sun Sep 11 02:09:42 UTC 2011

On Sat, 10 Sep 2011 11:53:48 +0100, Graeme Dargie wrote:
> I am trying to mount a samba share that is on a FreeBSD 8.2
> server to another FreeBSD 8.2 server,
> Mount_smbfs -I <IP> //user at host/share /mountpoint
> It then asks for a password, I enter the users password
> and then get mount_smbfs: unable to open connection:
> syserr = Authentication error
> Dmesg is showing smb_co_lock: recursive lock for object 1
> I have samba integrated with Active Directory, so I then thought
> ah maybe adding the user to AD would help, so I have done so
> using the same password etc still no joy, I have make sure the
> user has access rights on the samba share, restarted samba and
> the same error persists, any ideas ?

Sorry, my indivudal knowledge on "Windows" related things
is very limited, but maybe you need to add some information
into /etc/nsmb.conf?

Maybe like this:




where SERVERNAME and USERNAME correspond to the server's name
and the username you use to access the share (with the proper

See "man nsmb.conf" for details.

Parts of those information should then be reflected in /etc/fstab,
maybe like this:

	//user at SERVERNAME/share  /smb/share  smbfs  rw,noauto  0  0

This should allow you to use

	# mount /smb/share

a bit easier (and automatically, if desired).

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list