Updating emacs fails

Lowell Gilbert freebsd-questions-local at be-well.ilk.org
Sun Oct 23 16:44:07 UTC 2011

"John R. Levine" <johnl at iecc.com> writes:

>> On 23/10/2011 09:03, John R. Levine wrote:
>>>>    checking for tparm in -lncurses... no
>>>> but that's not correct.  libncurses should certainly contain that
>>>> symbol.  I get a 'yes' there on my stable/8 machine.  As -lncurses is
>>>> part of your LDFLAGS ... hmmm... do you have libncurses on your system
>>>> anywhere other than in /lib ?
>>> I have the ncurses-5.9 package installed from ports.  Several gnome
>>> programs depend on it:
>>> pkg_delete: package 'ncurses-5.9' is required by these other packages
>>> and may not be deinstalled:
>>> aalib-1.4.r5_6
>>> gnome-games-2.32.1_2
>>> guile-1.8.8
>>> libcdio-0.82_2
>>> libxine-1.1.19_7
>> Interesting.  Can you try moving /usr/local/lib/libncurses.* and
>> /usr/local/include/ncurses.h aside temporarily and then rebuild emacs?
>> If that works, then looks like you've found a bug in the editors/emacs
>> port, which should be reported to the port's maintainer.
> Yup, that fixed it.  I'll file a bug report.  I tried rebuilding some
> of the packages that allegedly depend on the ncurses port, and they
> all seemed to work OK, so the right solution may be to deprecate the
> ncurses port or fold it into the mainline system.

The way it's supposed to work is that emacs will depend on (and link to)
ncurses if it's installed when the emacs port is built, and to the base
system curses if not.  I just did a quick test, and this was just what
did happen.  So at least part of the problem is local to your system...

More information about the freebsd-questions mailing list