Invalid fdisk partition table found

Robert traveling08 at
Wed Nov 23 20:45:18 UTC 2011


[robert at dell64] ~> uname -a
FreeBSD dell64.shasta204.local 8.2-STABLE FreeBSD 8.2-STABLE #34: Fri
Nov 18 06:43:01 PST 2011
root at dell64.shasta204.local:/usr/obj/usr/src/sys/GENERIC  amd64 

I have two Lexar Professional 600X 16GB compact flash cards that are
unusable. fdisk shows:

[robert at dell64] ~> fdisk /dev/da1
******* Working on device /dev/da1 *******
parameters extracted from in-core disklabel are:
cylinders=29 heads=64 sectors/track=32 (2048 blks/cyl)

parameters to be used for BIOS calculations are:
cylinders=29 heads=64 sectors/track=32 (2048 blks/cyl)

fdisk: invalid fdisk partition table found
Media sector size is 512
Warning: BIOS sector numbering starts with sector 1
Information from DOS bootblock is:
The data for partition 1 is:
sysid 165 (0xa5),(FreeBSD/NetBSD/386BSD)
    start 32, size 59360 (28 Meg), flag 80 (active)
	beg: cyl 0/ head 1/ sector 1;
	end: cyl 28/ head 63/ sector 32
The data for partition 2 is:
The data for partition 3 is:
The data for partition 4 is:

It shows only 28 MB instead of 16GB. I have tried to change the type
from 165 (FreeBSD) to msdosfs types 6 11 or 12 using fdisk -u and fdisk
-i and also "sade". I do not get and error but when finished it still
shows the same data. 

I have tried to zero it out using " dd if=/dev/zero of=/dev/da1 bs=1m
and nothing changes. I have tried different block sizes and counts to
no avail.

Is there any way I can restore these CF cards to 16GB? Any help or
suggestions will be greatly appreciated.


More information about the freebsd-questions mailing list