Serial console with incorrect terminal set

J65nko j65nko at
Wed Nov 16 20:15:36 UTC 2011

On Wed, Nov 16, 2011 at 3:52 PM, James Edwards <jedwards at> wrote:
> Hi All,
> I have two servers currently colocated, one running FreeBSD 8.2/amd64 ,
> and the other is a Sun Netra T1 that I am attempting to install FreeBSD
> 8.2 on, over serial.
> When the system booted up, I was presented with a list of console options
> and I chose the first option, I believe to be ANSI (I have a knack for
> never picking the right one).  The keyboard mapping was a bit screwed up,
> but somehow I managed to get to the Fixit shell.  In order to test that I
> had my secondary NIC setup correctly, I just ran 'ping' and now
> it wont stop.
> If I hit 'Ctrl+C', it keeps going.  I tried 'Ctrl+Z' in order to attempt
> to suspend it so I can kill the process, but that brings up the 'Abort,
> Restart, Continue' screen, but it gets interrupted by ping.  I tried
> sending a break command using '~#', but I can't get to the OpenFirmware to
> restart in attempt to pick the correct terminal settings.  IIRC, the break
> is not supported without a kernel that supports it.
> It could be easier to call my ISP and have someone power down the machine
> for me, as the Netra has LOM.  In a worse case scenario, I can swing by
> and do it myself after work.
> My question is, is there another way to either 1) Stop ping or 2) Get to
> the openfirmware console?

You can stop ping with :
    $ pkill -TERM ping

>From the ping man page:

-c count
	     Stop after sending (and receiving) count ECHO_RESPONSE packets.
	     If this option is not specified, ping will operate until inter-

So with something like "ping -c4" , it would stop after 4 pings.

Good luck ;)


More information about the freebsd-questions mailing list