X server and xinit works excellent....almost.

Samuel Magnusson samuel.magnusson5 at bredband.net
Tue Nov 8 01:30:33 UTC 2011

Hi everyone!

I'm quite new to BSD and installed it on my old Pentium to try to learn 
the unixverse from bottom up. My first aim is not just getting the 
system running for surfing the web or something, not even to be 
productive, but to understand why and how it runs.    (Or else, why it 
runs not?:)  And that, of course, brings me here to write my first 
query. This (foolish?) wish to understand may also explain why I bother 
to be curious about something that may be of little, if any, practical 
concern since my X server display runs well with twm and awesome so 
far...  except for some minor anomalies.

My antique system is: Pentium 4, Geforce 2 MM/MX, with (not so antique) 
FreeBSD-8,2-Release, Xorg - fresh update from ports a couple of days ago 
(latest version of todays but don't remember the version nr) (...Eh..yes 
that means that my Pentium is sleeping for the moment and I'm writing 
this from my laptop with, ehm.. Window...something.)

Now the 4 different reasons for my unhappiness:

1.  I can´t zap the server with Ctrl-Alt-Backspace. Nothing at all 
happens. I have checked that it isn't disabled in xorg.conf, and even 
tried to put in the reverse boolean value there.  Not that I couldn't 
live without zapping, but...when I know about it that it should be there 
and it is taken fom me I feel an URGE to get the zap!

2.  Not surprisingly I was also unable to use the Ctrl-Alt-Keypad+/- for 
zooming between the different resolution modes. But then I remembered 
that I had changed configuration from vesa driver to nouveau (with some 
patch that I downloaded according to instructions in ports). When I 
switched back to vesa it worked! Still no zapping though, and no higher 
resolution than 1024x768. I therefore would like to get it to work with 
the nouveau also. (And to Zap them both! ;)
Or are there other ways, using alternative drivers perhaps? (beside 
upgrading graphics card...)

3.  When I started the X server manually, and just giving the vtXX 
option (without starting any client) the system went black and didn't 
respond. I couldn't zap it (as you know), but I couldn't even resort to 
the console with Ctrl-Alt-F1 (or any Fn) which otherwise works normally. 
I had to resort to hardware reset and boot from single user mode. This 
problem is not present if I just start the server with X :0 and let it 
choose the tty by itself. Then it works fine to go Ctrl-Alt-F1 and start 
xterm -display:0 with full functionality. Experimenting with this I 
discovered that if I started the first way, with option vtXX and the 
system went black, I actually still could reach the server from my 
laptop and ssh-login, and start xterm from there. Well in xterm I could 
just type exit and the X server went down smoothely.

4. Also xinit behaves strangely on my system. It works perfectly with my 
.xinitrc-script, so that is not the problem. But when I wanted to just 
start an xterm without a window manager, like "xinit xterm [options]" it 
should, according to the book, ignore .xinitrc and go for the options 
given to it. But it doesn't!! Instead it ignores my wish for a naked 
xterm (I'm pervert, I know..) and starts up twm in all it's glory as if 
reading .xinitrc was a craving it couldn't resist (like mine for zap). I 
had to change the name of .xinitrc so it couldn't find the beauty for it 
to obey. Then it  gave me my xterm. But still no good, because it also 
tries to start it's own default xterm in the upper left corner. And that 
one xterm behaves sickly, the cursor is just flimmering and if I type in 
something it immediately disappears, as if someone was leaning on the 
backspace. The other xterm (the one that I asked for) has no prompt and 
while I can write things in there and press return, xterm behaves like 
it was a text editor simply moving the cursor to next line as if it 
didn't just receive a command. There is one command though that it 
responds to, and that is: exit. It wants to go home. This is a funny 
problem. I guess it is not important, because when used for what it is 
mostly supposed to do - reading .xinitrc - the program works 
excellently. But still...

I guess 1-2 could be a problem with drivers, 3-4 with X and xinit, but 
what do I know?

Help is very much appreciated!

(Well, I guess I don't NEED your help as in *URGENT* and needing food, 
or even as in needing a screwdriver, because when I get the zap and zoom 
and naked xinitiated xterm and the tty of my choice, I plan to never or 
very seldom use them.  But I sure WANT your help.  And maybe there is 
some hidden functionality here that is lacking and will show itself a 
problem later on when trying heavier wms and desktops)

I wish you a nice day!

More information about the freebsd-questions mailing list