Why some flash sites don't work?

Yuri yuri at rawbw.com
Wed Nov 2 23:14:35 UTC 2011

On 11/02/2011 15:33, Adam Vande More wrote:
> In regards to the second, I just tried it on a new clean install of 9 
> RC 1 and it didn't work.  However it worked after I installed 
> flashblock.  There seems to be a least one secondary flash object on 
> that page which prevents the video from playing.  However, I will add 
> on rare occasion I've found a video like this and it actually will 
> play eventually, perhaps after hours of waiting.  I think the reason 
> for this is that the linuxulator doesn't perfectly emulate Linux 
> system calls, and when you run flash that which targets these system 
> calls, the npviewer cannot proceed until those calls are finished.  In 
> those cases, quite a bit of time can elapse until those faulty 
> syscalls end hence the very long delay before video playback.
> That's just a theory, and I'm happy to be proven wrong.  Or even 
> better, proven right and fixed.  In the meantime, you now have 
> workarounds for both videos.  I'm sure you can get the bottom of the 
> trouble with first video with some tenacity, as the problem must exist 
> in your home directory.

Workaround for only one by changing the user, and the other one just 
doesn't work for any user.

It would be easier to have standalone nspluginplayer working, but it 
doesn't. Do you know why it doesn't work as it used to?
nspluginplayer type=application/x-shockwave-flash 
for example fails to show video for me too for all users.


More information about the freebsd-questions mailing list