Why some flash sites don't work?

Adam Vande More amvandemore at gmail.com
Wed Nov 2 22:33:21 UTC 2011

On Wed, Nov 2, 2011 at 5:10 PM, Yuri <yuri at rawbw.com> wrote:

>  On 11/02/2011 14:19, Adam Vande More wrote:
> It comes from the rest of the instructions section, namely
> "nspluginwrapper -v -a -i".
> Sorry I missed this one.
> Now, after this is done and ~/.mozilla/plugins are identical for both
> users, my new user shows this link
> http://belapan.by/archive/2009/07/10/media_yakubovich fine, but the old
> user has the same problem as before.
> And this link
> http://www.reuters.com/video/2011/11/01/greek-referendum-disappoints-markets?videoId=224096981&videoChannel=2602both of them don't show at all. (pressing the arrow doesn't play any video)

Well we can then say there is something in your home directory preventing
the first video from playing.  Perhaps some type of flash setting, I don't

In regards to the second, I just tried it on a new clean install of 9 RC 1
and it didn't work.  However it worked after I installed flashblock.  There
seems to be a least one secondary flash object on that page which prevents
the video from playing.  However, I will add on rare occasion I've found a
video like this and it actually will play eventually, perhaps after hours
of waiting.  I think the reason for this is that the linuxulator doesn't
perfectly emulate Linux system calls, and when you run flash that which
targets these system calls, the npviewer cannot proceed until those calls
are finished.  In those cases, quite a bit of time can elapse until those
faulty syscalls end hence the very long delay before video playback.

That's just a theory, and I'm happy to be proven wrong.  Or even better,
proven right and fixed.  In the meantime, you now have workarounds for both
videos.  I'm sure you can get the bottom of the trouble with first video
with some tenacity, as the problem must exist in your home directory.

Adam Vande More

More information about the freebsd-questions mailing list