Arduino UNO - upload not working

Michael mlmichael70 at
Fri Jul 29 23:01:54 UTC 2011


Can anybody confirm that Arduino UNO is working fine with FreeBSD?

I'm having problems with uploading my sketches. Arduino IDE says:

Binary sketch size: 3620 bytes (of a 32256 byte maximum)
avrdude: stk500_getsync(): not in sync: resp=0x00

And it doesn't upload anything. Uploading on Windows works fine. Also 
once the sketch is uploaded on Windows then I can receive data on 
FreeBSD via Serial Monitor. It's just Upload that doesn't work.

It's recognized by my system as:
ugen0.2: <Arduino (> at usbus0
umodem2: <Arduino ( Arduino Uno, class 2/0, rev 
1.10/0.01, addr 2 > on usbus0
umodem2: data interface 1, has CM over data, has break

Also sysctl says:
dev.umodem.2.%desc: Arduino ( Arduino Uno, class 2/0, rev 
1.10/0.01, addr 3

I'm running FreeBSD 8.2-RELEASE-p2 with Arduino 0022 (with a patch to 
resolve the readlink problems). I'm using uarduno kernel module (tried 
both versions 1.00 and 1.02a) and avrdude (tried both vanilla ports and 
with a patch).

Run out of ideas and switching back to Windows kills my productivity 
(and fun!). If it works for you then at least please let me know that 
it's doable.

Thank you, Michael

More information about the freebsd-questions mailing list