use of menus crashes Firefox?

Rolf Nielsen listreader at
Tue Jan 18 23:20:05 UTC 2011

2011-01-18 23:56, Keith Seyffarth skrev:
> OK. This is still being a problem.  I've removed Firefox 3.6 from my
> system and installed Firefox 3.5. Use of menus doesn't cause 3.5 to
> crash, but it sill has problems. On some web sites, the browser dumps
> core. For example trying to log in, create an account, or retrieve a
> password at which leaves this core (as processed
> by gdb):
> Core was generated by `firefox-bin'.
> Program terminated with signal 12, Bad system call.
> #0  0x29d7f16b in ?? ()
> Now, again, this is in Firefox 3.5. That message isn't very informative
> to me, but maybe it is helpful to someone else?
> Again, this started after updating GTK on December 18 or so, following
> the instructions in /usr/ports/UPDATING
> Among the things that will cause Firefox to dump core in 3.5 or 3.6 are
> visiting some web sites (see above), accepting a signed secure
> certificate the first time (once it crashes Firefox, it's not a problem
> on subsequent visits), attempting to accept a questionable certificate
> (either telling Firefox to accept the certificate permanently or not),
> or exiting Firefox.
> In firefox 3.6, anything that generates a menu will also crash the
> browser.
> I have tried
> So far I have tried the following:
> * Remove the .mozilla directory and start firefox without extensions,
>    plugins, or customizations
> * Force reinstall of Firefox (portupgrade -F)
> * Remove and reinstall Firefox
> * Force reinstall of the mouse input driver
> * Remove and reinstall xorg and components
> * Remove and reinstall Fluxbox window manager
> * pkg_deleteing all firefox plugins and nspluginwrapper
> * Uninstalling Firefox 3.6 and installing Firefox 3.5 (helpful, but not
>    fixed)
> * running portupgrade -aOW again
> I'm wondering if this can't be fixed short of formatting and starting
> over, but I'd really hope to avoid a very M$Windows solution like
> that... Any further ideas?
> Keith S.
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to "freebsd-questions-unsubscribe at"

Are you by any chance overriding CFLAGS in /etc/make.conf? Or perhaps 
even compiling using a gcc version not in the base system? I had that 
exact problem with Firefox 3.6 (and with Thunderbird as well) and menus 
when compiling with gcc45 and/or overriding CFLAGS. It went away when I 
re-built Firefox (well, actually, I re-built everything, world, kernel 
and all the ports) using the stock compiler and removed all CFLAGS 


More information about the freebsd-questions mailing list