Installing port x11-toolkits/gtk20 fails mysteriously

Olaf Seibert O.Seibert at
Mon Jan 10 17:18:33 UTC 2011

Chip Camden <sterling <at>> wrote:
>  Portmaster users:
>    # pkg_delete -f gtkmm-2.20\* gtk-2.20\*
>    # portmaster -a

I tried that, but this was the result:

# pkg_delete -f gtkmm-2.20\* gtk-2.20\*
pkg_delete: no such package 'gtkmm-2.20*' installed
pkg_delete: no such package 'gtk-2.20*' installed

I also don't (seem to) have 'atkmm-*' or 'gtkmm*'.

Fortunately all this is in a chroot so it doesn't affect my installed
system. I do have a /usr/ports/packages/All/gdk-pixbuf-2.22.1.tbz file
and "pkg_info *gdk*" thinks it is installed.

# pkg_info *gdk*
Information for gdk-pixbuf-2.22.1:

A graphic library for GTK+

The GdkPixBuf library provides a number of features:

        - Image loading facilities.
        - Rendering of a GdkPixBuf into various formats:
          drawables (windows, pixmaps), GdkRGB buffers.
        - A cache interface


Looking inside that tar file shows the desired file. pkg_add wanted -f
to install it, since it claimed that

pkg_add: package 'gdk-pixbuf-2.22.1' or its older version already installed

Weid. But at least it works now. So thanks!

(sorry for not threading properly, but gmane doesn't seem to tell me the


More information about the freebsd-questions mailing list