ROOT on ZFS with MBR partitions

Gautham Ganapathy gautham at
Mon Feb 28 05:00:26 UTC 2011

On Sun, Feb 27, 2011 at 12:45 AM, Daniel Staal <DStaal at> wrote:
> --As of February 27, 2011 12:26:04 AM +0000, Slawomir Wojtczak is alleged to
> have said:
>> ... but none of them seems to work, after installation it hangs at boot
>> like that:
> --As for the rest, it is mine.
> Hmm.  Interesting.  I'm having the same result when trying the 'root on ZFS,
> boot from UFS' guide here:
> <>
> Anything interesting happening during your install?  I have an error late in
> the process (During 'Step 3.1') with this command:
> Fixit# mv boot bootdir/
> It gives me an error saying that /bin/cp can't found/executed.  (I've been
> trying to work around using `bin/cp -pRP boot bootdir/`.  Note the lack of
> the leading slash.)
> I had tried several of the other installs from
> <> successfully, but I don't think I'd
> tried the MBR install.
> Daniel T. Staal

I had the same problem. Today, I tried using the PCBSD dvd to install
FreeBSD on ZFS (with /boot on UFS). It kept giving errors just before
completion. However, some comments I found while googling about that
problem mentioned that the installation seemed to have completed,
which seems to be the case. Both FreeBSD and FreeDOS are now installed
on the same drive (in a VM, I'll try this on real h/w next). Still not
sure what caused the error during installation though.

Gautham Ganapathy

More information about the freebsd-questions mailing list