ROOT on ZFS with MBR partitions

Daniel Staal DStaal at
Sun Feb 27 00:45:24 UTC 2011

--As of February 27, 2011 12:26:04 AM +0000, Slawomir Wojtczak is alleged 
to have said:

> ... but none of them seems to work, after installation it hangs at boot
> like that:

--As for the rest, it is mine.

Hmm.  Interesting.  I'm having the same result when trying the 'root on 
ZFS, boot from UFS' guide here:

Anything interesting happening during your install?  I have an error late 
in the process (During 'Step 3.1') with this command:
 Fixit# mv boot bootdir/

It gives me an error saying that /bin/cp can't found/executed.  (I've been 
trying to work around using `bin/cp -pRP boot bootdir/`.  Note the lack of 
the leading slash.)

I had tried several of the other installs from 
<> successfully, but I don't think I'd 
tried the MBR install.

Daniel T. Staal

This email copyright the author.  Unless otherwise noted, you
are expressly allowed to retransmit, quote, or otherwise use
the contents for non-commercial purposes.  This copyright will
expire 5 years after the author's death, or in 30 years,
whichever is longer, unless such a period is in excess of
local copyright law.

More information about the freebsd-questions mailing list