editors/openoffice-org-3.3.0: serious issue with X11

Pavlo Greenberg sir_dog at onet.com.ua
Thu Feb 3 09:33:59 UTC 2011

> On 02/02/11 10:25, Anonymous wrote:
>> "O. Hartmann"<ohartman at zedat.fu-berlin.de>  writes:
>>> Hello.
>>> I just upgraded openoffice-3.2.1 to openoffice-org-3.3.0 and found
>>> myself in a serious issue. Opening openoffice works only sporadically,
>>> in most cases I get the error:
>>> XDM authorization key matches an existing
>>> client!/usr/local/openoffice.org-3.3.0/openoffice.org3/program/soffice.bin
>>> X11 error: Can't open display:
>>>     Set DISPLAY environment variable, use -display option
>>>     or check permissions of your X-Server
>>>     (See "man X" resp. "man xhost" for details)
>> Have you tried to add the following to xdm-config
>>    DisplayManager*authName: MIT-MAGIC-COOKIE-1
>> or adjusting permissions using xhost(1)?
> I did. Adding DisplayManager*authName: MIT-MAGIC-COOKIE-1 to xdm-config
> didn't make the problem disappear, only a global 'xhost +' helped. I
> also tried xhost + localhost:0.0 and all IP- or name-based combinations
> even FQDN/IP of the host, without success, except pure 'xhost +'.
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscribe at freebsd.org"
I solved the problem by adding "xhost +local:<my_user>" in ~/.xsession (I
don't use any DE anymore, just WM, so in case of KDE or GNOME it may be
another config file).
But I'm agree with you, OOo's behavior after the last update is abnormal.

More information about the freebsd-questions mailing list