editors/openoffice-org-3.3.0: serious issue with X11

O. Hartmann ohartman at mail.zedat.fu-berlin.de
Thu Feb 3 08:42:07 UTC 2011

On 02/02/11 10:25, Anonymous wrote:
> "O. Hartmann"<ohartman at zedat.fu-berlin.de>  writes:
>> Hello.
>> I just upgraded openoffice-3.2.1 to openoffice-org-3.3.0 and found
>> myself in a serious issue. Opening openoffice works only sporadically,
>> in most cases I get the error:
>> XDM authorization key matches an existing
>> client!/usr/local/openoffice.org-3.3.0/openoffice.org3/program/soffice.bin
>> X11 error: Can't open display:
>>     Set DISPLAY environment variable, use -display option
>>     or check permissions of your X-Server
>>     (See "man X" resp. "man xhost" for details)
> Have you tried to add the following to xdm-config
>    DisplayManager*authName: MIT-MAGIC-COOKIE-1
> or adjusting permissions using xhost(1)?

I did. Adding DisplayManager*authName: MIT-MAGIC-COOKIE-1 to xdm-config 
didn't make the problem disappear, only a global 'xhost +' helped. I 
also tried xhost + localhost:0.0 and all IP- or name-based combinations 
even FQDN/IP of the host, without success, except pure 'xhost +'.

More information about the freebsd-questions mailing list