FreeBSD 8 LiveFS - How To Start SSHD?

Drew Tomlinson drew at
Sun Dec 25 05:37:45 UTC 2011

On 12/24/2011 4:47 PM, Robert Bonomi wrote:
>>  From owner-freebsd-questions at  Sat Dec 24 16:58:02 2011
>> Date: Sat, 24 Dec 2011 14:35:35 -0800
>> From: Drew Tomlinson<drew at>
>> To: freebsd-questions at
>> Subject: FreeBSD 8 LiveFS - How To Start SSHD?
>> I've lost a drive in my FBSD 8.? box.  I have a FBSD 8.1 LiveFS CD from
>> which I've booted.  I'd like to get sshd running so I can connect
>> remotely and have the ability to browse, copy/paste, etc. while I see
>> what I might be able to salvage before replacing my drive.
>> I've found these directions:
>> I can do the "Configure the network connection", the  "setup login shell
>> for root", and the "Prepare SSH" part.  However the "Enable, configure,
>> and start sshd" part doesn't seem to apply and really doesn't make sense.
>> Bottom line is that after running /mnt2/use/sbin/sshd, I can see the
>> process in ps output.  However when I attempt to connect to sshd as
>> root, my connection is immediately closed.  I'm thinking it's a
>> PermitRootLogin yes issue and I'm missing something but I've read and
>> re-read that section and verified that /etc/ssh/sshd_config contains
>> PermitRootLogin yes.
> If it happens -before- getting the login prompt, it is *NOT* a PermitRootLogin
> isssue.  If you get the login prompt, put in 'root', and are -then- cut off
> it is a root login issue.
> Immediate connect and disconnect points to an issue with the IP address
> you're connecting from -- as sshd (or possibly tcpwrapper) sees it, that is.
> could be "no reverse-DNS", or inconsistent forward/reverse.  Could be that
> the address/domain is blocked in /etc/hosts.{deny,allow}

Thank you.  Seems I had to restart sshd to get it to read hosts.allow?  
I didn't think that would be the case but it worked.

Now I am having a PermitRootLogin issue because it's happening after the 
login prompt.  Another poster also suggested "ssh -vv" which I ran 
locally on the LiveFS machine and it confirm that the connection is 
closed after public key auth fails and it moves to keyboard-interactive.

Don't know what to try next.  Seems that I can only kill sshd by 
rebooting.  It ignores "kill -15" or "kill -9" commands.

Thanks for your help.


Like card tricks?

Visit The Alchemist's Warehouse to
learn card magic secrets for free!

More information about the freebsd-questions mailing list