Atheros 9285 - not operating?

Da Rock freebsd-questions at
Wed Dec 21 13:19:32 UTC 2011

This is getting less and less funny as I get deeper in this. I tried a 
lower end model of the same laptop with 8.1 and 8.2 and completely 
failed to get the atheros 9285 to work (although I did have partial 
success building from head (9) on 8.1. Wouldn't work after that.

Along came 9.0-RC3 and I thought I had it made: the bsdinstall setup the 
card on a new laptop with wpa and all. After some days of work, left the 
unit alone for a while and the network went down. Error was "bb hang 
detected (0x4) resetting.

Tried a few things to get it to work, and failed. Rebooted, and still 

Firstly, when I first set it up I set it standalone. After the install 
I've setup lagg failover (done that many times before). I plug in UTP 
and it comes good, dhcp an address and ping- good, unplug and ping- no good.

ifconfig wlan0 scan shows my bssid and others in the area. The others 
are on different channels with six degrees separation.

This is not the only unit with this to happen either. The problem is 
identical on another brand of laptop with this card installed using 9.0-RC3.

Dmesg does not show any error that could be responsible. It only show 
the inital detection of the hardware, although one message shows up 
right after detection that may be of note: [ath] AR9285E_20 detected; 
using XE TX gain tables.

The only thing I can conclude with the circumstances of the error (in 
both units) is that the card is timing out somehow and not waking up 
properly. I can't see any sysctl setting that would change this though.

Any help appreciated.


More information about the freebsd-questions mailing list