Xorg error: New athlon laptop, radeonhd video - unable to load fbdev

Warren Block wblock at wonkity.com
Mon Dec 19 17:05:06 UTC 2011

On Mon, 19 Dec 2011, Da Rock wrote:

> On 12/19/11 21:31, Da Rock wrote:
>> I hate to come with this kind of a query, but my googling hasn't come 
>> across a satisfactory answer.
>> I'm running an install on a brand new laptop for a client, and I'm trying 
>> to get X up using xdm- nothing. The logs says it failed to load fbdev 
>> because there is no data module.
>> I try uninstalling fbdev and running a rebuild of xorg- its still using the 
>> builtin configuration and still can't load fbdev. No devices detected.
>> I run Xorg -configure, and it shows the radeon card fine, 2 displays. Still 
>> working with the config file, but it seems fine.
> correction - its dual display issue that I've never had trouble with before 
> (I also have installed on a HTPC with same memory, phenom quad core, uses a 
> radeon HD card and a NVidia HD card). And no, the Xorg -config 
> /root/xorg.conf.new [-retro] doesn't work as it is locking up and I can't 
> even ctl-alt-backspace, I have to acpi power off to shut the system down. 
> Google's still not giving me any hope... :( Last time I came across this 
> level of issue was with a solo vintage intel card on yet another laptop- it 
> froze the system too.
> BTW, who says multicard vga is rare?

Some newer laptops have dual GPUs, an onboard Intel combined with one 
from another vendor for higher performance.  There's hot-switching 
between the two, but AFAIK it's not supported in FreeBSD.  There may be 
a BIOS option to disable one or the other.  There should still be two 
video outputs.

More than one video card at a time is a different issue, which is also 
unsupported on FreeBSD AFAIK:
(WW) VGA arbiter: cannot open kernel arbiter, no multi-card support

More information about the freebsd-questions mailing list