Xorg error: New athlon laptop, radeonhd video - unable to load fbdev

Da Rock freebsd-questions at herveybayaustralia.com.au
Mon Dec 19 12:46:49 UTC 2011

On 12/19/11 21:31, Da Rock wrote:
> I hate to come with this kind of a query, but my googling hasn't come 
> across a satisfactory answer.
> I'm running an install on a brand new laptop for a client, and I'm 
> trying to get X up using xdm- nothing. The logs says it failed to load 
> fbdev because there is no data module.
> I try uninstalling fbdev and running a rebuild of xorg- its still 
> using the builtin configuration and still can't load fbdev. No devices 
> detected.
> I run Xorg -configure, and it shows the radeon card fine, 2 displays. 
> Still working with the config file, but it seems fine.
correction - its dual display issue that I've never had trouble with 
before (I also have installed on a HTPC with same memory, phenom quad 
core, uses a radeon HD card and a NVidia HD card). And no, the Xorg 
-config /root/xorg.conf.new [-retro] doesn't work as it is locking up 
and I can't even ctl-alt-backspace, I have to acpi power off to shut the 
system down. Google's still not giving me any hope... :( Last time I 
came across this level of issue was with a solo vintage intel card on 
yet another laptop- it froze the system too.

BTW, who says multicard vga is rare?
> WTF? This is essentially the same hardware as another laptop I've 
> setup (same video card - same brand CPU, just bigger and faster), and 
> its fine. Both are AMD, the original is athlon dual core, the new is 
> phenom quad core.
> The googling failed as my searches came up with either root has access 
> and user doesn't, or mixed intel/ati. Neither are the case here...
> Cheers
> _______________________________________________
> freebsd-questions at freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to 
> "freebsd-questions-unsubscribe at freebsd.org"

More information about the freebsd-questions mailing list