Major version changes using portupgrade?

Sergio Tam tam.sergio at gmail.com
Sun Dec 4 07:29:46 UTC 2011


2011/12/2 Matthew Pounsett <matt at conundrum.com>:
>
> I'm trying to do a major version upgrade of postgres from 8.4 to 9.1.  I've dumped the db and uninstalled the postgres-server port, and I'd like to use portupgrade to handle the client upgrade, since it has a number of dependencies that probably should be recompiled against the new client libs (and I'd like to keep the package's +REQUIRED_BY file properly updated anyway).
>
> I was expecting the following to work:
> sudo portupgrade -rf -o databases/postgresql91-client databases/postgresql84-client
>
> However, I'm running into a problem where the ports makefiles, and by extension portupgrade, are detecting that the two packages conflict, and so the 9.1 client won't even build[1].
>
> This seems to be the sort of situation described by the -o example in the portupgrade man page, but I haven't been able to figure out how to make it work.  Does anyone have any suggestions?
>
> Thanks!
>
> --
>
> [1]
> [Updating the pkgdb <format:bdb_btree> in /var/db/pkg ... - 140 packages found (-1 +0) (...) done]
> --->  Upgrading 'postgresql-client-8.4.8' to 'postgresql-client-9.1.1_1' (databases/postgresql91-client)
> --->  Building '/usr/ports/databases/postgresql91-client'
> ===>  Cleaning for postgresql-client-9.1.1_1
> cd /usr/ports/databases/postgresql91-client && make config;
>
> ===>  postgresql-client-9.1.1_1 conflicts with installed package(s):
>      postgresql-client-8.4.8
>
>      They install files into the same place.
>      You may want to stop build with Ctrl + C.
> ===>  Vulnerability check disabled, database not found
> ===>  License check disabled, port has not defined LICENSE
> ===>  Found saved configuration for postgresql-client-9.1.1_1
> => postgresql-9.1.1.tar.bz2 doesn't seem to exist in /usr/ports/distfiles/postgresql.
> => Attempting to fetch ftp://ftp.se.postgresql.org/pub/databases/relational/postgresql/source/v9.1.1/postgresql-9.1.1.tar.bz2
> postgresql-9.1.1.tar.bz2                      100% of   14 MB 1349 kBps 00m00s
>
> ===>  postgresql-client-9.1.1_1 conflicts with installed package(s):
>      postgresql-client-8.4.8
>
>      They will not build together.
>      Please remove them first with pkg_delete(1).  <----------------pay attention here
> *** Error code 1


 postgresql-client-8.4.8

make deinstall


Tip. always run portaudit -F first.

Regards


More information about the freebsd-questions mailing list