can't determine sound card driver to use in /etc/rc.conf

Antonio Olivares olivares14031 at
Wed Apr 20 01:31:24 UTC 2011

On Mon, Apr 18, 2011 at 9:32 PM, Polytropon <freebsd at> wrote:
> On Mon, 18 Apr 2011 20:53:41 -0500, Antonio Olivares <olivares14031 at> wrote:
>> Apparently it works, but I put in some small speakers, but could not
>> get music to play.
> On some machines, speakers do not activate automatically,
> they need a "driver" that switches the connector to active.
> Also check mixer settings. ALWAYS check them. :-)
>> Installed mplayer from within ports,
>> # cd /usr/ports/multimedia/mplayer
>> # make install clean
>> and tried to play some mp3's and got a codec error :(, since machine
>> is 64 bit installing codecs from mplayer site does not work :(, and
>> linux compatibility is not installed.
> Use command line tools like madplay or mpg123 for testing.
> Also consider using xmms as a versatile MP3 (and OGG/Vorbis)
> media player.
Mplayer played some ogg files that I had correctly and sound is working :)

snd_hda did the trick :)
>> Sorry for drifting out of
>> original sound problem, but I also tried to play a dvd and it failed
>> to load since atapi cam was not  in /boot/loader.conf because cd/dvd
>> drive is old style(not SATA)

This is now working correctly :), added the command in /boot/loader.conf

> That doesn't matter. I have parallel ATA devices here that
> play nicely with ATAPICAM (mainly in use for CD and DVD
> recording). But you shouldn't need to have ATAPICAM in order
> to play DVDs. I know that mplayer has a configuration option
> for that... maybe it's sufficient to link /dev/acd0 to /dev/dvd

link exists /dev/dvd -> /dev/acd0
but dvd does not play :(

> (per /etc/devfs.conf) to provide the default location, or
> use -dvd-device <dev> to name it on the command line. Also
> make sure you have the required codecs installed.
Since the machine is 64 bit having the codecs does no good :(, I ran
the configuration and tried to install Realplayer which tried to pull
linux compatibility which I did not want and reran config.
> Going
> through "make config" in mplayer (or mencoder) is always
> a good choice.

However, playing dvd's does not seem to work :(
I try to run
$ mplayer dvd://1 -dvd-device /dev/acd0
and it complains about not finding some vob
Sorry for not posting exact error will do so tomorrow as soon as I can.

> --
> Polytropon
> Magdeburg, Germany
> Happy FreeBSD user since 4.0
> Andra moi ennepe, Mousa, ...

Thanks to all folks who have advised me.  I am close to setting up the
system to my liking.



More information about the freebsd-questions mailing list