USB disk on CS5536 unstable

Patrick Lamaiziere patfbsd at
Thu Sep 30 22:34:16 UTC 2010

Le Thu, 30 Sep 2010 21:10:59 +0200,
Anselm Strauss <amsibamsi at> a écrit :

> Maybe sending it to just the USB list was too specific ...
> On 09/30/10 00:08, Anselm Strauss wrote:

> > I have an ALIX board that has an AMD Geode and the CS5536 companion
> > chip with integrated USB on it. When I connect a USB disk I have
> > observed various problems. For example when I run fsck_ufs on a 250
> > GB partition the process gets stuck in biord state and fsck reports
> > unreadable sectors. When I do a dd over the whole disk and direct
> > it to /dev/null it suddenly returns with no error, but having read
> > only a small fraction of the disk. I tried it with two different
> > disks and two different ALIX boards. I'm pretty sure the disks are
> > okay since I tried them on other hardware.
> > 
> > As far as I know there was some trouble with the chip regarding
> > timeouts. Under load after some time the USB just stops responding.
> > I have tried 8.0 and 8.1. Is there any known problem? How can I
> > track this down?

I use a Soekris Net5501 (amd Geode and cs5536 chip) too since
FreeBSD 6.X and I did not notice any problem with an usb disk (myne is
a 160 go disk). It is my home "all-in-one box" doing backup and NAS
(some times I make a backup on a usb drive)

I follow the Soekris mailing list and I do not remembered anymone
complaining about usb disk problems too.


More information about the freebsd-questions mailing list