Unable to access CDROM device to play music

Polytropon freebsd at edvax.de
Sat Sep 25 22:49:19 UTC 2010

On Sat, 25 Sep 2010 17:32:27 -0400, Carmel <carmel_ny at hotmail.com> wrote:
> I have tries several different disks, all with the same results. These
> CDs work fine on my Windows machines.
> I used information at URL:
> http://www.freebsd.org/doc/handbook/creating-cds.html
> 18.6.9 Using the ATAPI/CAM Driver
> This worked fine on my previous version of FreeBSD.

I'm also using this setup for many years now.

> Now, entering the
> command:
> 	mount -t cd9660 /dev/cd0 /mnt
> Gets me this error message:
> mount_cd9660: /dev/cd0: Input/output error

Does this refer to an audio CD? In that case: Won't work.

Mounting a data CD (ISO-9660 filesystem) _should_ work. From the
error message, I don't think you have permission problems, but make
sure that - as you're using ATAPICAM - have sufficient permissions
for /dev/cd*, /dev/xpt* and /dev/pass*.

Have you tried mounting using the ATAPI driver?

	# mount -o ro -t cd9660 /dev/acd0 /mnt

Does this work for data CDs?

> MPlayer cannot play a file from a CD because it never finds a CD to
> use. It did work previously.

Okay, seems that you're accessing the audio CD by mplayer, I now
understand. You can specify -dvd-device <dev> as a command line
parameter for mplayer to indicate which drive to use. Oh, and
many programs use $CDROM and $CDPLAYER environment variables.

> > Are you accessing the drive by ATAPI or ATAPICAM?

To make sure there are no other problems, try with ATAPI, too,
as shown above.

Magdeburg, Germany
Happy FreeBSD user since 4.0
Andra moi ennepe, Mousa, ...

More information about the freebsd-questions mailing list