Unable to access CDROM device to play music

Carmel carmel_ny at hotmail.com
Sat Sep 25 21:32:32 UTC 2010

On Sat, 25 Sep 2010 22:31:39 +0200
Polytropon <freebsd at edvax.de> articulated:

> On Sat, 25 Sep 2010 08:09:23 -0400, Carmel <carmel_ny at hotmail.com>
> wrote:
> > I am using FreeBSD 8.1 / amd64 with Platform Version 4.5.1 (KDE
> > 4.5.1) if that matters.Before updating my system to FreeBSD 8.1 /
> > amd64, I had the 7.3 /32 bit version installed. I completely erased
> > the HD prior to installed the newer version so as to eliminate any
> > accumulated garbage that might be hanging around. Previously, I was
> > able to play CD Audio files without any problem. The "cdcontrol"
> > program worked fine and I was able to play music files while using
> > KDE using its audio player.
> > 
> > I now find that I can no-longer achieve that goal. When I place an
> > audio CD into the PC, this error message is displayed: (It will
> > probably wrap)
> > 
> > Unable to mount Audio Disc
> > DBus error org.freedesktop.DBus.Error.NoReply:
> > Message did not receive a reply (timeout by message bus)
> You cannot mount audio CDs.
> The important lines from your system log are:
> acd0: FAILURE - READ_BIG ILLEGAL REQUEST asc=0x64 ascq=0x00 
> SCSI status: Check Condition
> SCSI sense: ILLEGAL REQUEST asc:64,0 (Illegal mode for this track)
> This seems to indicate that the CD cannot be read. Can it be read
> with a different drive? Maybe the drive is faulty. Or the media
> is. Can you check the media in a "hardware CD player"?

I have tries several different disks, all with the same results. These
CDs work fine on my Windows machines.

I used information at URL:


18.6.9 Using the ATAPI/CAM Driver

This worked fine on my previous version of FreeBSD. Now, entering the

	mount -t cd9660 /dev/cd0 /mnt

Gets me this error message:

mount_cd9660: /dev/cd0: Input/output error

> > I am at a loss here. I don't believe I made any radical changes from
> > the configuration I was using in my older FreeBSD installation.
> First of all, HAL seems to be interfering. To check, make sure HAL
> is not running, then do "cdcontrol play 1". Have the "mixer" program
> push all volumes up.
> > I might add that MPlayer cannot see the drive either; although, it
> > use to work fine.
> In how far does mplayer "see a drive"?

MPlayer cannot play a file from a CD because it never finds a CD to
use. It did work previously.

> > This problem exists whether KDE is running or not. The
> > "cdcontrol" player will open and close the door on the device;
> > however, no sound is emitted.
> Does the drive have a phones connector at the front? Does it maybe
> play from there? Playing audio CDs is a feature of drives that does
> not neccessarily need CPU / system attention (except for starting
> the playback by a drive command).
> Are you accessing the drive by ATAPI or ATAPICAM?


> > Normal 'notification' sounds are emitted so I know
> > the speakers, etc. are working correctly. The KDE start-up
> > notifications works just fine.
> So no problem on this side.

More information about the freebsd-questions mailing list