GnuPG not allowing passphrase entry

C. P. Ghost cpghost at
Sun Sep 5 15:18:15 UTC 2010

On Wed, Sep 1, 2010 at 2:49 PM,  <jhall at> wrote:
> Ladies and Gentlemen,
> I an attempting to decrypt a file using the following command line.
> /usr/local/bin/gpg --output /usr/local/scripts/test. --no-default-keyring
> --secret-keyring 09-2010.sec --keyring --always-trust
> --decrypt --recipient Wed_Sep_1_00_01_00_CDT_2010 at
> /usr/local/scripts/test.gpg
> When doing so, I receive the following output.
> You need a passphrase to unlock the secret key for
> user: "Wed_Sep_1_00_01_00_CDT_2010 (Monthly Archive Encryption Key)
> <Wed_Sep_1_00_01_00_CDT_2010 at>"
> 1024-bit ELG key, ID E8E5F849, created 2010-09-01 (main key ID 557E7C04)
> gpg: cancelled by user
> gpg: encrypted with 1024-bit ELG key, ID E8E5F849, created 2010-09-01
>      "Wed_Sep_1_00_01_00_CDT_2010 (Monthly Archive Encryption Key)
> <Wed_Sep_1_00_01_00_CDT_2010 at>"
> gpg: public key decryption failed: General error
> gpg: decryption failed: No secret key
> While the prompt to enter a passphrase does appear, it is skipped without
> allowing me to enter anything.
> gpg-agent is running.  I am running FreeBSD 8.0. My GnuPG version is
> 2.0.14

gpg-agent (and pinentry-*) causes all sorts of trouble. Are you sure all
environment variables are pointing to it when you run gpg (notably
GPG_AGENT_INFO and GPG_TTY)? What about the permissions
of the sockets?

> I have also tried adding the public and secret keys to the default keyring
> and receive the same result.
> Thanks for your help.


Cordula's Web.

More information about the freebsd-questions mailing list