two ata-related problems

Lowell Gilbert freebsd-questions-local at
Fri Sep 3 13:11:04 UTC 2010

perryh at writes:

> Two questions about installing FreeBSD 8.1 on a Dell Precision 420
> (yes, I know it's old):

I have a similar machine running as a lab tool.

> 1. Should FreeBSD 8.1 be able to recognize a 100MB ATAPI Zip drive?
>    I'm not finding it in the dmesg, although BIOS Setup recognizes
>    it.  (It and a CDROM are on the secondary IDE channel; I've tried
>    with each of them as master and either way the CD is recognized
>    but the Zip is not.)

The default kernel definitely won't, but with the vpo device enabled, it
probably will.  There's a kernel module for that, so you can try 
"kldload vpo".

> 2. It currently has the original A01 BIOS.  I'm going to have to
>    update that, because it doesn't recognize the 320GB drive I've
>    added as a new boot drive.  With the 320GB installed as unit 0
>    (master) on the primary IDE channel, the A01 BIOS won't even
>    recognize the previously-working 40GB drive which is now unit 1;
>    so the BIOS disables that channel entirely keeping FreeBSD from
>    seeing those drives either.
>    A BIOS upgrade should be straightforward, but while Googling
>    I ran into a posting where someone apparently had a lot of
>    trouble with a BIOS upgrade for one of these of boxes.  Thus
>    the question:  Has anyone here had any experience, either good
>    or bad, with running FreeBSD on one of these with an upgraded
>    BIOS?  If so, which version?  I found A06, A07, A10, A11, and
>    A13 on Dell's FTP site.

A01 gave me a bunch of problems, although I don't really remember the
details (it was more than five years ago!) at this point.  BIOS upgrades
were no problem at all.  I stopped upgrading the BIOS once everything
worked -- at least, everything I noticed.

Good luck.

More information about the freebsd-questions mailing list