two ata-related problems

perryh at perryh at
Fri Sep 3 09:32:04 UTC 2010

Two questions about installing FreeBSD 8.1 on a Dell Precision 420
(yes, I know it's old):

1. Should FreeBSD 8.1 be able to recognize a 100MB ATAPI Zip drive?
   I'm not finding it in the dmesg, although BIOS Setup recognizes
   it.  (It and a CDROM are on the secondary IDE channel; I've tried
   with each of them as master and either way the CD is recognized
   but the Zip is not.)

2. It currently has the original A01 BIOS.  I'm going to have to
   update that, because it doesn't recognize the 320GB drive I've
   added as a new boot drive.  With the 320GB installed as unit 0
   (master) on the primary IDE channel, the A01 BIOS won't even
   recognize the previously-working 40GB drive which is now unit 1;
   so the BIOS disables that channel entirely keeping FreeBSD from
   seeing those drives either.

   A BIOS upgrade should be straightforward, but while Googling
   I ran into a posting where someone apparently had a lot of
   trouble with a BIOS upgrade for one of these of boxes.  Thus
   the question:  Has anyone here had any experience, either good
   or bad, with running FreeBSD on one of these with an upgraded
   BIOS?  If so, which version?  I found A06, A07, A10, A11, and
   A13 on Dell's FTP site.

dmesg (from a USB boot) attached.  The reported 320GB (on an add-in
card) is a twin of the one described above that isn't recognized on
the primary on-board channel.  I want them on separate channels to
improve mirroring performance.
-------------- next part --------------
Copyright (c) 1992-2010 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
	The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 8.1-RELEASE #0: Mon Jul 19 02:55:53 UTC 2010
    root at i386
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel Pentium III (731.47-MHz 686-class CPU)
  Origin = "GenuineIntel"  Id = 0x683  Family = 6  Model = 8  Stepping = 3
real memory  = 536870912 (512 MB)
avail memory = 506056704 (482 MB)
ACPI APIC Table: <DELL   WS 420 >
ioapic0: Changing APIC ID to 1
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
acpi0: <DELL WS 420 > on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, f00000 (3) failed
acpi0: reservation of 1000000, 1ef9e000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x808-0x80b on acpi0
cpu0: <ACPI CPU> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <Intel 82840 host to AGP bridge> on hostb0
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
vgapci0: <VGA-compatible display> mem 0xf4000000-0xf5ffffff,0xfcffc000-0xfcffffff,0xfc000000-0xfc7fffff irq 16 at device 0.0 on pci1
pcib2: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci2: <ACPI PCI bus> on pcib2
xl0: <3Com 3c905C-TX Fast Etherlink XL> port 0xdc80-0xdcff mem 0xf8fffc00-0xf8fffc7f irq 16 at device 4.0 on pci2
miibus0: <MII bus> on xl0
xlphy0: <3c905C 10/100 internal PHY> PHY 24 on miibus0
xlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
xl0: Ethernet address: 00:b0:d0:22:5a:14
xl0: [ITHREAD]
pci2: <multimedia, audio> at device 6.0 (no driver attached)
atapci0: <VIA 6421 SATA150 controller> port 0xdc70-0xdc7f,0xdc50-0xdc5f,0xdc30-0xdc3f,0xdc10-0xdc1f,0xd8e0-0xd8ff,0xd400-0xd4ff irq 19 at device 11.0 on pci2
atapci0: [ITHREAD]
ata2: <ATA channel 0> on atapci0
ata2: [ITHREAD]
ata3: <ATA channel 1> on atapci0
ata3: [ITHREAD]
ata4: <ATA channel 2> on atapci0
ata4: [ITHREAD]
pcib3: <PCI-PCI bridge> at device 14.0 on pci2
pci3: <PCI bus> on pcib3
ahc0: <Adaptec aic7899 Ultra160 SCSI adapter> port 0xec00-0xecff mem 0xfafff000-0xfaffffff irq 18 at device 10.0 on pci3
ahc0: [ITHREAD]
aic7899: Ultra160 Wide Channel A, SCSI Id=7, 32/253 SCBs
ahc1: <Adaptec aic7899 Ultra160 SCSI adapter> port 0xe800-0xe8ff mem 0xfaffe000-0xfaffefff irq 19 at device 10.1 on pci3
ahc1: [ITHREAD]
aic7899: Ultra160 Wide Channel B, SCSI Id=7, 32/253 SCBs
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci1: <Intel ICH UDMA66 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xffa0-0xffaf at device 31.1 on pci0
ata0: <ATA channel 0> on atapci1
ata0: [ITHREAD]
ata1: <ATA channel 1> on atapci1
ata1: [ITHREAD]
uhci0: <Intel 82801AA (ICH) USB controller> port 0xff80-0xff9f irq 19 at device 31.2 on pci0
uhci0: [ITHREAD]
uhci0: LegSup = 0x2f00
usbus0: <Intel 82801AA (ICH) USB controller> on uhci0
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
atrtc0: <AT realtime clock> port 0x70-0x7f irq 8 on acpi0
fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc0: [FILTER]
fd0: <1440-KB 3.5" drive> on fdc0 drive 0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [ITHREAD]
psm0: model Generic PS/2 mouse, device ID 0
uart0: <16550 or compatible> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
uart0: [FILTER]
uart1: <16550 or compatible> port 0x2f8-0x2ff irq 3 on acpi0
uart1: [FILTER]
ppc0: <Parallel port> port 0x378-0x37f,0x778-0x77f irq 7 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/8 bytes threshold
ppc0: [ITHREAD]
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
plip0: [ITHREAD]
lpt0: <Printer> on ppbus0
lpt0: [ITHREAD]
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xc7fff,0xc8000-0xcdfff,0xce000-0xcffff pnpid ORM0000 on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 731471411 Hz quality 800
Timecounters tick every 1.000 msec
md0: Preloaded image </boot/mfsroot> 4423680 bytes at 0xc0fb5504
usbus0: 12Mbps Full Speed USB v1.0
ugen0.1: <Intel> at usbus0
uhub0: <Intel UHCI root HUB, class 9/0, rev 1.00/1.00, addr 1> on usbus0
acd0: CDROM <Lite-On LTN483S 48x Max/PD02> at ata1-master PIO4 
uhub0: 2 ports with 2 removable, self powered
device_attach: afd0 attach returned 6
ugen0.2: <vendor 0x0457> at usbus0
umass0: <vendor 0x0457 USB Mass Storage Device, class 0/0, rev 2.00/1.00, addr 2> on usbus0
umass0:  SCSI over Bulk-Only; quirks = 0x0000
ad4: 61136MB <PATRIOT MEMORY 64GB SSD 02.10104> at ata2-master UDMA100 SATA 1.5Gb/s
acd1: DVDR <PIONEER DVD-RW DVR-212D/1.24> at ata3-master UDMA66 SATA 1.5Gb/s
ad8: 305245MB <Hitachi HDT725032VLAT80 V54OA4NA> at ata4-master UDMA133 
umass0:2:0:-1: Attached to scbus2
da0 at ahc0 bus 0 scbus0 target 0 lun 0
da0: <FUJITSU MAG3091MP 5506> Fixed Direct Access SCSI-3 device 
da0: 160.000MB/s transfers (80.000MHz DT, offset 127, 16bit)
da0: Command Queueing enabled
da0: 8683MB (17783249 512 byte sectors: 255H 63S/T 1106C)
da1 at umass-sim0 bus 0 scbus2 target 0 lun 0
da1: <UDISK PDU16_1G 61G2.0 0.00> Removable Direct Access SCSI-2 device 
da1: 1.000MB/s transfers
da1: 960MB (1967616 512 byte sectors: 64H 32S/T 960C)
GEOM: da1: geometry does not match label (255h,63s != 64h,32s).
GEOM: da1: media size does not match label.
Trying to mount root from ufs:/dev/md0

More information about the freebsd-questions mailing list