xptioctl pass driver usb scsi driver problem (solved)

Alejandro Imass ait at p2ee.org
Fri Mar 26 21:32:42 UTC 2010


Just wanted to share with the list that I solved this problem today,
and looking at the recent archives this has come up recently without
any solutions so here it is.
FYI, there was an answer by Andrew Thompson in the thread "USB2 vs
SCSI pass-through?" of Feb 25th 2010 which hinted at the solution but
the OP never manifested if he had actually solved the problem.

If you get this in dmesg when you plug in your usb mass storage device:

xptioctl: pass driver is not in the kernel
xptioctl: put "device pass" in your kernel config file

It probably means that HAL (you are probably running Gnome) has
interfered with the assigning if dev by the kernel. All you have to do
is disable hal for a moment, unplug and replug and voila! it' s fixed.
Then you safely start HAL back up again. There is no doubt, a better
solution, like fixing the root of the HAL problem but this simple
workaround will avoid ruining your day.

1) /usr/local/etc/rc.d/hald stop
2) unplug and re-plug the device
3) dmesg, camcontrol, mount, etc.
4) /usr/local/etc/rc.d/hald stop

Alejandro Imass

More information about the freebsd-questions mailing list