FreeBSD and vmware

Manolis Kiagias sonicy at
Wed Mar 17 20:54:53 UTC 2010

On 17/03/2010 10:34 μ.μ., Erik Norgaard wrote:
> Hi:
> I have a dual boot Windows/FreeBSD which I use for work, I just tried
> today to create a virtual machine with vmware on windows to start up
> the installed FreeBSD.
> This works except for three problems:
> - The disk device is renamed, I suppose I can just dublicate the
> entries in the fstab, the devices not found won't be mounted, I'll get
> an error but problem solved?

Best would probably be to label the devices and use the labels instead
of device names. It will work without changes in both bare metal and
vmware. (Or maybe use the ufsid labels.) Check this out:

> - I can't see the network devices from vmware

The emulated network device is probably different than the one you are
using. I believe most recent vmware versions emulate an Intel NIC, i.e.
em0. Use ifconfig to check and add a line in rc.conf for this
> - I can't start xwindows, no monitor is found

This is definitely fixable, make sure you install xf86-video-vmware port
and create an xorg.conf by hand if needed (probably not) using the
Handbook instructions.

More information about the freebsd-questions mailing list