Problem using Portmaster to upgrade installed ports via packages only

Alexandre L. axelbsd at
Tue Jun 29 20:37:05 UTC 2010

I have done tests last days, and now I can set PACKAGESITE correctly in user's .cshrc (I have unset the parameter in root's .cshrc).
Else, I have set /usr/local/etc/portmaster.rc, as described in the portmaster's manpage.

Here my /usr/local/etc/portmaster.rc


I don't know (or understand) if I have to set a value to PM_SU_VERBOSE
I have tried to set PM_SU_VERBOSE=/usr/local/bin/sudo without success
If you can help me here, I have read the manpage hundred times, but haven't found where I am wrong. 

Then I have tried without the line PM_SU_VERBOSE, just with PM_SU_CMD=/usr/local/bin/sudo
I can install without problem packages with 
$ portmaster -P -a -x openoffice

But if there is no package available for the port, I got the message (it is an example) : 

=> libpng-1.4.3.tar.xz doesn't seem to exist in /usr/ports/distfiles//.
=> /usr/ports/distfiles/ is not writable by you; cannot fetch.
*** Error code 1

Stop in /usr/ports/graphics/png.
*** Error code 1

Stop in /usr/ports/graphics/png.

===>>> make failed for graphics/png
===>>> Aborting update

===>>> Update for png-1.4.1_1 failed
===>>> Aborting update

===>>> There are messages from installed ports to display,
       but first take a moment to review the error messages
       above.  Then press Enter when ready to proceed. 

In the 2 cases, my user's password has been asked, and I have typed it.

My portmaster version is 2.32.

I haven't got problem if I do 
$ sudo portmaster -P -a -x openoffice

I think my problem come from the parameter for sudo in portmaster.rc but I don't know how to set it. I have really read the manpage a lot.

Thanks for your help.


More information about the freebsd-questions mailing list