Problem using Portmaster to upgrade installed ports via packages only

Doug Barton dougb at
Thu Jun 24 22:24:48 UTC 2010

On 06/24/10 06:10, b. f. wrote:
>> Hi,
>> On my FreeBSD box running 8.0-RELEASE-p3, I have tried to use
>> PORTMASTER tool to upgrade my ports via packages only. Then I added
>> the following line to my user's .cshrc file and root's .cshrc file,
>> and re-opened user's session : setenv PACKAGESITE
>> Then I typed this linde into a console :
>> % sudo portmaster -PP -a -x openoffice

There is a procedure for using sudo with portmaster described in the man
page. That procedure is preferable because it uses your user environment
for everything except where root privileges are actually necessary.

What I suspect is happening here is that sudo is stripping your
environment which means that portmaster never sees the PACKAGESITE
variable. I tried it just now with csh, setting the environment variable
as you did, but using portmaster with sudo in the way described in the
man page and it worked fine.

If you would prefer to continue using 'sudo portmaster' that's fine, but
you'll need to place the relevant information (such as PACKAGESITE) in
~/.portmasterrc or /usr/local/etc/portmaster.rc. BTW, if you're going to
go this route, you're probably better off with PACKAGEROOT, but either
way should work. See the man page for more information.

>> Elsewhere, I have tested these FTP repositories (for PACKAGESITE
>> variable) without success : 

Spelling counts. :)




	... and that's just a little bit of history repeating.
			-- Propellerheads

	Improve the effectiveness of your Internet presence with
	a domain name makeover!

More information about the freebsd-questions mailing list