IPv6 rtadv on FreeBSD 8.1?

Vincent Hoffman vince at unsane.co.uk
Fri Jul 30 18:19:48 UTC 2010

On 30/07/2010 18:48, Carl Johnson wrote:
> I have running versions of 7.3 and 8.0, so I tried experimenting with
> 8.1 in VirtualBox, but I ran into a couple of problems.  I have an 8.0
> system that is running a IPv6 tunnel to sixxs.net, and it is running
> rtadvd to act as the gatway for my network.  On the 8.1 system I
> enabled IPv6 in rc.conf, but it is not picking up the advertised
> address.  I can add it manually, and have put it in rc.local for now,
> but it seems it should work automatically as my others do.  I noticed
> that the ifconfig output shows a new line that is not in 8.0:
>         nd6 options=3<PERFORMNUD,ACCEPT_RTADV>
> Is there something that has changed in 8.1 that I have to enable, or
> is there a problem with 8.1?  IPv6 is working to the extent that it
> did assign a link-local address, and I can use that address as long as
> I specify the interface.  My configuration is the same, and I didn't
> have to enable anything on the others to get the global address
> assigned automatically.
> Thanks for any advice.
I dont knw if its expected or not but try running
sysctl net.inet6.ip6.accept_rtadv=1

(to make it persistent  echo "net.inet6.ip6.accept_rtadv=1" >>
/etc/sysctl.conf )


More information about the freebsd-questions mailing list