8.1-RELEASE ia64

Michael Powell nightrecon at hotmail.com
Mon Jul 26 14:33:17 UTC 2010


Samuel Martín Moro wrote:

> Hi
> 
> I would like to install FreeBSD-8.1 ia64, so I downloaded
> FreeBSD-8.1-RELEASE-ia64-disc1.iso.
> 
> When I boot from a burnt CD, the screen keeps black, with the
> blinkingunderscore,
> nothing else happend.
> When I make an USB bootable stick, I've got a message saying that
> /boot/loader was not found.
> 
> Having a look into /boot, I noticed that indeed, there's no loader
> anymore. But there a loader.efi, which wasn't in FreeBSD-7.2-RELEASE (the
> last I tried).
> I tried copying loader.efi to loader, but as expected, it says me 'invalid
> format' and still does not want to boot...

Perfectly normal and to be expected. IA64 utilizes a different boot loader 
paradigm known as EFI. More info on EFI can be found here:

http://en.wikipedia.org/wiki/Extensible_Firmware_Interface
 
> What happened to loader?
> Did I download the wrong iso?

Probably. The IA64 architecture is a completely different beast than x86. If 
your processor is a Xeon or some other regular Intel desktop type you need 
to use the amd64 iso image. 

> Did I miss something?
> 
> Also, why other archs have their -memstick.img, and ia64 have not?
> 
Maybe IA64 will not boot from USB because of the EFI boot loader 
requirement. 

-Mike





More information about the freebsd-questions mailing list