Samba gives "invalid PT_PHDR" after upgrading from 7.2-RELEASE to 7.3-RELEASE

David Brodbeck gull at
Sun Jul 18 20:42:35 UTC 2010

On Jul 7, 2010, at 10:12 AM, David Brodbeck wrote:

> On Wed, July 7, 2010 2:20 am, mcoyles wrote:
>>> Today I tried using "portupgrade -R -f samba34" to rebuild samba  
>>> and all
>>> of its dependencies, but I'm still getting the same error. I'm a  
>>> little
>>> surprised that a minor version upgrade broke this so thoroughly.   
>>> I went
>>> back over the release notes to see if I missed any obvious caveats  
>>> about
>>> upgrading, but if I did, I'm not seeing it.
>> David - have a look here...
> OK, I see.  It looks like rtld is part of world, not a port, so then  
> the
> question becomes, why didn't freebsd-update update it for me?  Is  
> there a
> way I can force a binary upgrade, or do I need to download the  
> source and
> rebuild things that way?

I ended up downloading the 7.3 livefs ISO, booting off of it, and  
replacing /libexec/ with the one from the CD.  That fixed  
the problem.

I suspect the reason freebsd-update didn't upgrade it properly is it  
appears it's impossible to replace this file on a running system, even  
in single-user mode.  Maybe there should be something in the release  
notes about a 7.2 -> 7.3 upgrade being impossible to do properly  
except by booting from CD?

More information about the freebsd-questions mailing list