Virtualbox Networking Issues

Chris Maness chris at
Fri Jul 16 01:36:55 UTC 2010

On Thu, Jul 15, 2010 at 3:06 PM, Remko Lodder <remko at> wrote:
> On Jul 16, 2010, at 12:05 AM, Chris Maness wrote:
>> On Thu, Jul 15, 2010 at 3:00 PM, Remko Lodder <remko at> wrote:
>>> On Jul 15, 2010, at 11:57 PM, Chris Maness wrote:
>>>> I tried the second Intel adapter in the list and it worked under bridge mode.
>>> This is really unsatisfying, can you generate an ifconfig -a and report it back so that we can see what you did?
>>> did you assign multiple interfaces to the machine? are they all bridged or?
>>> I want to make sure that others can learn from this, and that is only possible when you shed a little light on the
>>> things that you did and what caused problems. would you be able to help us with that?
>>> --
>>> /"\   Best regards,                        | remko at
>>> \ /   Remko Lodder                      | remko at EFnet
>>> X    |
>>> / \   ASCII Ribbon Campaign    | Against HTML Mail and News
>> Yes, I will give a more detailed blow by blow a little latter on.  I
>> am on baby duty right now ;o)
>> Chris
> OK that is a fair excuse :) goodluck with that and please tell us what you did and how you did resolve it. It's one of the strenghts
> of email archives, if people hit the search string they might be able to see how you resolved it, and thank you for it later :)
> Cheerio
> R
> --
> /"\   Best regards,                        | remko at
> \ /   Remko Lodder                      | remko at EFnet
> X    |
> / \   ASCII Ribbon Campaign    | Against HTML Mail and News

Things I tried:

With all three vbox module inserted into the kernel

NAT, Bridge, with the PC-Net FAST  Not able to ping anything (even the
gateway)  I also tried ifconfig by hand
NAT, Bridge, and Host-only with the first intel card on the list.
Same response as above.
NAT and Bridge with 2nd Intel card used.  DHCP worked under nat, but
was unable to ping the outside internet.
Bridge worked perfectly with DHCP and was able to talk to the outside
world.  Bridge is preferred anyhow as I can set up a static with a
public IP for access from the outside world.

My host is headless, so I am running virtualbox headless and it works
like a champ with the following command:

# VBoxHeadless --vnc --vncport 5902 --startvm FreeBSD

Note:  I had a similar issue with a FreeBSD client running under
windows being picky as to which card I selected.  This was a couple of
years ago.  Also, I think I see the same issue with the system time
running wildly off from net time.  On my old virtualbox system the
system clock was so unsteady that ntp would not even lock it down.

Chris Maness

More information about the freebsd-questions mailing list