Booting FreeBSD from Compact Flash

Aiza aiza21 at
Tue Jul 6 23:49:34 UTC 2010

Graham Bentley wrote:
> OK I confess that this is associated with FreeNAS however
> it seems rather quiet over there on the support forums and I
> know there are some knowledgeable BSD people on this
> list who may be willing to help on this ...
> Compact Flash: Kingston 4GB 45x Elite Pro [CF/4GB-S]
> Target Mainboard: VIA EPIA-V10000
> * I D/L'ed FreeNAS-i386-embedded-
> * I checksumed it with md5sum for WindowsXPP - it matched
> * I used physdiskwrite v0.5.2 to write the image to CF on my desktop PC
> * I hoooked up the CF to the target mainboard and booted the kernel
> Now this is where things go awry .... I end up at this prompt ;
> mountroot>
> I can see the Kinston is ID as ad0 a few lines above at ata0-master.
> If I enter ? I get a list of boot devices as follows ; ad0c ad0a ad0
> If I enter; mountroot> ufs:/dev/ad0a I get a 'panic: no init' message
> and a reboot ; no other choice of boot device gives any such result.
> CF boots perfectly hooked up to my desktop PC. On Via Mainboard
> I have tried switching off all IDE 'modes' to zero etc but still no joy.
> I tried using the verbose boot option and notice that following the CF
> card being ID'ed I get the following ;
> ad0 VIA check1 failed
> ad0 Adaptec check1 failed
> ad0 LSI (v3) check1 failed
> ad0 LSI (v2) check1 failed
> ado FreeBSD check1 failed
> Would I be right in thinking that its chipset support for this baord is 
> whats
> preventing access to the root of the OS/FS?
> And if it is, is it possible to add module support somehow?
> Thanks in advance of any help :)

Maybe this will be helpful

More information about the freebsd-questions mailing list