Weird build errors only on 3rd core of quad core CPU

Erich Dollansky erich at
Thu Jan 28 01:30:04 UTC 2010


On 28 January 2010 am 06:54:13 Pieter de Goeje wrote:
> I am suspecting a broken CPU, but am not sure.

it really looks like.

Are you sure it is a quad core and not just a triple core?

As already mentioned, you should check the stepping the software 
tells you but also what is actually written onto the CPU itself.

Try to get the CPU exchanged and see what happens then.

> These commands:
> cd /usr/ports/sysutils/hal
> cpuset -c -l 2 make
> Will always result in errors, for example this one:
> gmake: *** No rule to make target `@MAINTAINER_MODE_TRUE@',
> needed by `'.  Stop.
> *** Error code 1
> Sometimes the error occurs in a different place. When I check
> the input files, they are indeed broken. Gcc stops because of
> syntax errors for example.
> The configure process always completes, but apparently it
> creates broken files. When I run make on any other core, it
> always completes successfully: cpuset -c -l 0,1,3 make
> I've checked with script that the output of the build process
> is exactly the same, up until the error occurs. I've also tried
> to run cpuburn on that core, but it didn't find any problem.
> It's really weird that system is otherwise very stable.
> What do you guys think the problem is?
> CPU is AMD Athlon II X4 620. Running FreeBSD 8-STABLE/amd64.
> I've also tried -CURRENT, but it didn't help.
> Thanks!
> --
> Pieter
> _______________________________________________
> freebsd-questions at mailing list
> To unsubscribe, send any mail to
> "freebsd-questions-unsubscribe at"

More information about the freebsd-questions mailing list