DAve dave.list at
Thu Jan 21 19:25:55 UTC 2010

Polytropon wrote:
> On Thu, 21 Jan 2010 12:26:58 -0500, DAve <dave.list at> wrote:
>> Anyone using cgiwrap?
> No, so I may just give a quite generic advice, erm, guess. :-)
>> I am unable to get it to work. It continues to
>> claim it is not set uid root, but it is.
>> -rwsr-xr-x   2 root    nogroup   92396 Jan 21 11:33 cgiwrap
>                          ^^^^^^^
> Is "nogroup" intended? Check

Yes, my apache runs as nobody:nogroup on this server. I had changed it
to root:bin as it was set with sbox, and left it as root:root (as set by
the makefile), no difference.

> 	% ls -lno cgiwrap

-rwsr-xr-x  2 0  65533  - 92396 Jan 21 11:33 cgiwrap

> for anything untypical for a SUID executable.
> Furthermore, it would be helpful to know the full error
> message (if any).

Sure, "The cgiwrap executable(s) were not made setuid-root. This is
required for it to function properly. (SetUID root is needed in order to
change the uid to that of the script owner. This is an installation
error please make the executable setuid root, or use the 'make install'
method of installing the executables. "

Which I tried second. First I used the port cgiwrap with the above
result, then I built it myself and got the same error.



"Posterity, you will know how much it cost the present generation to
preserve your freedom.  I hope you will make good use of it.  If you
do not, I shall repent in heaven that ever I took half the pains to
preserve it." John Adams

More information about the freebsd-questions mailing list