Serious problems updating Current after switching to libxul.

keneasson keneasson at
Tue Jan 19 03:25:09 UTC 2010


I'm running Freebsd 8.0-Stable #9 Dec 17/09 on amd64. I'm running gnome, and at the time i started my update i was at Gnome 2.26

I went through UPDATING and tried to switch from firefox 2 which is marked ignore to libxul by changing WITH_GECKO=libxul removed firefox3 and installed firefox35
I used UPDATING to try and sort out libxul, but it seems i have some cyclic dependencies.

I use portmaster (i did try to rebuild things for portupgrade and try, but it had bigger problems and i couldn't even update the index.) I keep updating my ports tree (cvsup) i used portsnap, and it seems that was when my problems started, i rm -rf /usr/ports/* and cvsupped the entire thing back at one point.

I got an error which seems to have started the whole ugly affair with /usr/ports/Mk/ causing post patch issues, the main problem seemed to be e2fsprogs-libuuid which i was unable to rebuild due to it wanting a patch which from what i've read is now removed with firefox2, i deleted stuff till i got around that for now... but...

at present my key problem is a cyclic dependency when i try and rebuilt pretty much anything, with libxul as the main issue.

glib20 => libxul =>glib20 => libxul =>glib20 => libxul =>glib20 => libxul =>glib20 => libxul =>glib20 

I have tried installing the package for both. i've tried pkg_deleting both then installing the port, or using portmaster, i've tried portmaster --check-depends, i've tried portmaster -e to remove them and try and re-install them. I've removed about 1/2 my system and now have even more problems. (i removed gettext and now portmaster complains about missing not found. 

at best i get a much larger cyclic loop with:
glib20 => libtool22 => libiconv => gettetxt => atk => libgmp4 => farsight => gdm => libxul => glib20 

or some other combination of the cycle.

Can anyone help me get my system back up and running?

make.conf looks like this:
WWWDIR = /web/phpmyadmin
# Begin portconf settings
# Do not touch these lines
.if !empty(.CURDIR:M/usr/ports*) && exists(/usr/local/libexec/portconf)
.for i in ${_PORTCONF:S/|/ /g}
${i:S/%/ /g}
# End portconf settings
# added by use.perl 2009-09-19 16:22:20


More information about the freebsd-questions mailing list