[PHP] RE: Clean PHP 5.2.12 Build Core Dumping / Can't Build Port - FreeBSD 6.1

Don O'Neil lists at lizardhill.com
Tue Jan 12 00:31:06 UTC 2010

Ok.. just for grins I installed a new instance of 6.1, NO Patches, just
straight off the ISO...

I loaded the ports that came WITH the distro, and was able to make php 5.1.2

When I did a portsnap fetch, portsnap extract, then went into the
/usr/ports/lang/php5 and just typed make I get the same error...

SO as it seems, the port is broken, at least for working with FreeBSD 6.1.

Can anyone give me some hints on how to build this sucker by hand? Seems as
though there are a bunch of patches that are referenced in the distinfo

I REALLY need to get this taken care of asap, any help is appreciated.


> > > I tried adding WITHOUT_X11=yes to /etc/make.conf as well as
> X11BASE=
> > and
> > > X11BASE="", but I still get the same error.
> >
> > Remove them. This makes sure they are not defined, not even
> > empty (as in "#define BLA -> symbol 'BLA' is defined").
> >
> > > Where to go from here? Do I have and old version of something that
> is
> > > causing this? I get this error _right away_ before anything is even
> > built.
> >
> > It seems to be a check by the Makefile at port's top level.
> Ok... I have no definition for X11BASE anywhere, not in my env, not in
> my
> /etc/make.conf, nowhwere...
> However, it's still complaining about X11BASE being deprecated. I tried
> just
> adding WITHOUT_X11=yes in /etc/make, and without it. I even searched
> all the
> Makefiles in /usr/ports, and in the /usr/ports/lang/php5 dir to find
> any
> reference to X11, or X, or X11BASE, but nada... I don't even know where
> this
> error message is being generated from.
> I can't even do a basic make without it immediately spitting out the
> error:
> # make
> X11BASE is now deprecated.  Unset X11BASE in make.conf and try again.
> *** Error code 1
> Stop.

More information about the freebsd-questions mailing list